ZJ Beny EV charger review

HELP with New DLB Solar
I have the Charger without OCPP and have received the New DLB Solar but can’t make it work!
All is connected correctly, RS485 cable plugged and OK, DIP switch 4 in charger OFF: Start the DLB.
But the DLB shows “EVSE Offline” and the charger flashes yellow/1xRed.
When I plug the RS485 to the DLB, it shows HI, then 2 seconds the Grid/House/Solar display with values and then “EVSE Offline”. ANY Suggestions? Is there an other Service manual than the Install manual supplied?
Thanks for any help

Did you solve this?
I have just installed the DLB solar, but can’t make it work, “EVSE Offline” despite of being correctly connected.
Do you know where else we can get some support?

I know it was a while ago, but I’m curious: how is the cable to the DLB routed in that pic? Is it in the conduit with the power cable, or is it in the wall cavity?

Or can anyone else answer the more general question about how this cabling is done with smart chargers? I’m just trying to plan ahead…

@ShaneS, the comms (CAT 5/6) cable can be run inside the conduit along with the AC cable, but only if it is the 240V rated Pink cable.
The pink outer sheathing of the CBus CAT5 cable is rated to 240V AC as it may, for short runs be routed into a switchboard close to mains cable.

Otherwise, regular Blue CAT 5 cable can be run used in a separate conduit or just through the wall.

@Svarky, thank you! I have an electrician coming to put in a 15-amp socket, and I’m trying to future-proof it with 6mm2 cabling and running a comms cable at the same time. He’s coming in a couple of days, so looks like I need to chase up some pink cable.

I am have the same issue. However I noticed that the when the solar generation goes up it stays at 6AMP. But when the solar generation starts dropping due to, say shade due to cloud or decreasing generation in the afternoon, the charger jumps to full 32AMP by drawing power from grid. This happens even if the generation is still drops from 5KW to say 4.9KW this still happens. My usage during the day is never more than 700w. I think that defeats the purpose of PV only generation. Any suggestions? Did you manage to fix your issue?

@Eagle, it sounds like one of the CT clamps is around the wrong way.

Great Thread on the ZJBeny guys!

I had the BCP-A2N-L charger (OCPP version) installed a month ago, to charge a Tesla and BYD.
I am using Home Assistant (HA) to run the OCPP server, and control the Max Current at the Charger, based on Solar, or Amber Wholesale pricing etc.
This was all working fine, until a day or two ago, when the Maximum Current setpoint got stuck on 19A (of a max 32A set in the charger).
I then did the obvious reboots, resets, checking Config settings in the charger, and logs in HA.
I also upgraded firmware (to version 1.0.26) via OCPP pushed from HA which was reported by charger as successfull.
All to no luck. Still stuck on 19A.
HA logs state the limit value being accepted. (example below setting Max to 22A)

2023-07-07 13:11:50.511 INFO (MainThread) [ocpp] zjbeny: send [2,“2ef99948-786e-4efd-8141-fdea6214398e”,“SetChargingProfile”,{“connectorId”:0,“csChargingProfiles”:{“chargingProfileId”:8,“stackLevel”:10,“chargingProfileKind”:“Relative”,“chargingProfilePurpose”:“ChargePointMaxProfile”,“chargingSchedule”:{“chargingRateUnit”:“A”,“chargingSchedulePeriod”:[{“startPeriod”:0,“limit”:22.0}]}}}]
2023-07-07 13:11:50.703 INFO (MainThread) [ocpp] zjbeny: receive message [3,“2ef99948-786e-4efd-8141-fdea6214398e”,{“status”:“Accepted”}]

I have changed Charger config to Plug n Play via ZBOX app, and can get 32A delivered to EV in that mode.
Interestingly Bluetooth is available when E/Stop button is pressed. (It is reported that this OCPP model doesn’t have Bluetooth).
Changing back to OCPP, it goes back to 19A again! (both EV’s)
I have also tried changing the OCPP charge point path from ocpp16 to ocpp16j and no difference.

Any help would be greatly appreciated!

Hi. Just got a BCP-A2N-L charger (OCPP version) installed and I managed to get everything working as expected (via Bluetooth) apart from the wifi that cannot connect no matter what I try. I followed all the instructions about the wifi requirements and even tried a couple of older routers, making sure they were 2.4Ghz and WPA2 (personal). I even got the router 1 metre apart from the Beny… nothing. Any ideas? Is there a way to connect it via Ethernet?
While the hardware may be good, the software and documentation for this unit are dreadful :frowning:

Hi, I was wondering if anyone had tested a 3 phase (22 kW) ZJ Beny with a single phase car yet?

My question is how the Au Solar DLB handles unbalanced phases? If I’m exporting say 9 kW total (3 kW per phase) before plugging the car in, I’d like it to charge at the full 7.4 kW, but is this how the system behaves? Or does it balance per-phase, so would only send 3 kW to the car in this situation?

This from the DLB manual sounds promising, but I’d really like to hear that someone has empirically confirmed the behavior:

“The allowable power of EVC”=Max grid power (set via DLB)*(Phase of the current EV
charger)”+“The sum of the three phase
power of PV power” - “The sum of the three phase power of household load”

Did you ever solve the problem of the charge limit being stuck at 19A? I’m researching EVSE units and your setup sounds like something I might build.

Yes I did!
For some reason I had to send an OCPP command via Home Assistant Services tab, to clear all the charger profiles. Not sure why, but this fixed it.
Maybe something in a Home Asssistant update changed something.
Read further here if it ever comes up…


1 Like

Hi we have a z box and dlb nonsolar. We have low price power 9pm to 7am. So far we have to set start finish time manually in the app every day. As I understand it the app doesn’t permit this to saved and used everyday. Is that correct?

Thanks Shane
Was there a solution to this mysterious line coming somehow directly of the DB? My sparky ignored it, but I’ve had “Grid Phase Lost” error, with the following advice :
"Can not install DLB close to inverter.

  1. the L1 of home line should be wiring on the L1 terminal of DLB bottom, only L1, can not be L2 or L3:
    2)The N line of the home line should be wired on the N terminal of DLB bottom."

So as Shane asked - does anyone know what that page 25 means? There’s a thin dual wire included in the pack - surely that’s not wired direct from 240 to the DLB?

Mine only arrived last week, so I haven’t had a chance to arrange installation, but I was wondering the same thing. I’m guess it is indeed meant to be wired to 240v supply, but I’d love confirmation from @Svarky or anyone else who has one installed. The picture above of one installed in a fuse box shows what look like power wires going to those connections, but the angle makes it hard to be sure.

Yes, it looks like the new meter is definitely powered by a 240V AC supply. This is very common for solar energy meters as well. FYI: I haven’t used the new Beny chargers or BLDs.

Like most other energy meters, the 240V powers the unit and provides a reference voltage to ensure the grid voltage is within range and detect voltage drop issues (common with high loads).
If the small twin core cable supplied is AC voltage rated up to 300V (check for any small text on the cable sheath), then it is used for the voltage supply. It will only be drawing a few milliamps, so the cable does not need to be big. However, it should be connected via a 6A or 10A circuit breaker.

Thanks for the confirmation.

No rating. It’s actually two light cables with ferrules on each end, no text, but one blue and one brown. I guess getting the installer to use standard cable instead would be fine.

Bummer – more space to find. It couldn’t just come off an exisiting shared 20A house circuit? Seems a bit of overkill to have just that on its own circuit.

One thing that made me ignore a power supply was the Box getting power over ethernet from the Beny.
The limited factory advice I had for a distorted screen problem was to disconnect the RJ45 to cycle it up - which did fix the screen. But the continuing grid phase error hints there’s some input missing. Shame that every other diagram other than page 25 ignores the lines into the bottom of the box…
Be great to see how others have wired those inputs off the DB.

Hey @preeemo - one question that arises below, does your solar DLB have a power feed on the lower inputs?
This is the confusing page 25 of the new manual - showing a direct 240 feed off the DB, which is difficult to see if your sparky wired in.