ZJ Beny EV charger review

Hi all, new here, thank you all for your info so far,

I complained to ZJ Beny about the money spent on the original Solar DLB, and they supplied me the new one FOC, so happy with their response.

The new DLB is working as expected, charging perfectly, using the exact amount of energy, I use the PowerSensor APP to monitor my power, and its really accurate with the consumption.

I moved my power supplier to RED Energy, they have a EV TOU plan, this is awesome, off peak around 21c from my provider, but better with others, and 2 free hours every weekend, between 12 and 2pm Sat and Sun, smash it with full 32A all for free.

ZJ Beny app could support Wifi, Bluetooth and OCPP would be awesome, currently only Wifi & BT OR OCPP
Being able to schedule DLB options, so PV Mode between certain hours, Full Speed during other hours or days etc.
APP available via internet, its a pain as sometimes I will be away from home, and my FREE power alarm triggers, but I have no way of getting the APP to Full Speed, suppose a schedule would help this!

Understand no-one here has the power to change, but if we all keep requesting improvements from ZJ, we may get a fantastic system, so far, really happy to be able to charge the Tesla with sunlight only!


1 Like

@Matilde_Villanueva, the red and yellow lights sequence will indicate the problem.

The user manual tells you what the lights mean… See image below.

It may be the “Abnormal current” error. This might be due to a low voltage problem or a bad cable connection. What size cable is used to connect the EV charger to the main switchboard? If the cable is too small or the connections are not tight, it will heat up and cause a voltage drop and the current will become abnormal.

The size of the cable is 4mm2.
What I dont understand is that if the PV is disconnected (pannels are not functioning) the charger works correctly with no error.

The ct is placed around the main grid feed cable (1 cable, the one that comes from the street)

The Sparkie came back today and ensured the connections matched the latest manual. I reset everything, and it seemed to work for a few seconds before getting the dreaded “DLB Wiring Failure”. The arrows on the DLB unit definitely seem odd.

I can disable the DLB feature and the ZJBeny charger works fine, but it defeats the whole purpose of having a smart charger. The Sparkie insists the connection are as per the manual (which it looks to be), so I have no idea what to do now.

One thing you could try is disconnecting the solar CT and disable it as described on page 22 of the manual. If I understand correctly, it should then work, but just not display the solar value.

For those wondering how my ZJ Beny charger has been going. Overall it was pretty good once I figured out the CT configuration and set up the additional Solar DLB, and it’s good to see the company take the advice onboard and release an updated Solar DLB. However, the App has been unstable and often crashed, which made charging quite difficult at times. Also, having no remote access to the charger was a problem.

The Beny charger is still good value for money, but I’ve now upgraded to a Smappee EV charger which comes with all the equipment needed for load-balancing and solar-only charging. I’ll be using this charger from now on and reviewing how it performs. Overall, it seems like a very good quality charger backed by some very sophisticated smart energy management software.

Can any one with this charger confirm:
If I plug my car in does it charge automatically? Or do you need to use this RFID card to start charging?

I just bought one of these (single phase ocpp) but have been reading quite a few horror stories…

Yes, you can set it to start charging automatically using the “plug n play” setting.

Thank you! Just to confirm - this is also the ocpp version that has this option via charge hq?

I recently installed an ocpp version zj benny and, while i can connect to its default wifi for configuration, i cant get it to connect to my wifi. I just end up with a flashing gren light. Cant get it to charge in badic mode either with or without rfid card.

Had this issue when mine was installed. The settings for the OCPP server have to be correct for the first connection, otherwise it will keep flashing the green light indicating that wifi will not connect. Once the first connection goes through you can initiate charging with RFID if wifi is down or disconnected from OCPP server

Thanks, i set it up with the recommended alternate ocpp setting, and set my wifi up with a very simple guest network and different security and its now working as advertised. Happy to have it working but strange.

If you manage to get the app to work, please let me know how, couldn’t get it to connect

No joy on app, although i haven’t tried since i got it working on my wifi. I did read somewhere that the ocpp versions wasn’t compatible with the app. And i dont believe it has bluetooth. I assume that you, as i am, just control it through charge hq or a similar platform.

Just to confirm - does the ocpp version have an automatic start function when you plug in your car?

I have the bcp-bt2n-l version from the table below, which does indicate the it has Bluetooth and app compatibility but yeah using charge hq at the moment

Yes it can, mine is setup to do this

Hi all,
I’m new to EV charging world and hopefully I’ll be getting my Tesla model 3 soon. I have just installed a ZJ Beny BCP-AT2N-L with OCPP (by a certified electrician) and along with a smart meter installed on my Fronius solar inverter, I hope that using ChargeHQ app I will be able to utilise excess solar energy to charge my EV during the day and top it up at night during the off peak rate.

During the commissioning of the ZJ Beny charger, I could not get it to connect to my wifi network and to ChargeHQ server. I have entered all the settings recommended by ChargeHQ, but it failed to connect. I have tried multiple sources of wifi including hot-spotting from my iphone, still not connecting. So the wifi AP works and I can access the configuration page.
I also tried to connect to the unit using bluetooth, but the unit does not seem to have the bluetooth on as it does not show up on the bluetooth list neither on my iphone nor ipad.

Do I have a faulty ZJ Beny unit? Does anyone has any suggestions on how to resolve this connection issue? I’m sorry if this is a repeat question on this thread as this is a long thread and I may have missed the obvious solutions given before.

Thank you in advance and I hope someone out there can help me with this issue.

Have you tried the following from the chargehq site ZJ Beny Charger Configuration Guide

If the charger is still “Never Connected” then try using the non-SSL connection details. In Step 5 above, enter the following:

Select “SSL Unable”
Set the Central System Hostname to be ocpp.chargehq.net
Set the Central system Port to be 80

Hi eoinhan,
Thank you for the suggestion. Yes I followed the configuration guide and have been communicating with Andrew at ChargeHQ. It seems that your suggestion works. My ZJ Beny is now connected to chargehq server.
Just need to wait for my tesla to be delivered to start testing the solar tracking function.
Again thank you very much.